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1 Introduction

The Unite Log Analyser is an application for viewing and analysing logs from the Unite 
system and is intended to run on a PC.

The Unite Log Analyser makes it possible to filter and view logs graphically or in table 
format. The views can be exported and used in external applications, for example in 
Microsoft PowerPoint presentations.

This document is intended as a guide for installation, troubleshooting, maintenance and 
operation purposes and is relevant to the following personnel:

• Service Technician (installation and system trouble shooting)

• System Administrator

• User
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1.1 Abbreviations and Glossary

2 Technical Solution

Figure 1. The Log Analyser used in a typical Unite system.

Events in the Unite system, such as calls, messages, and alarms, are logged by the ESS and 
stored in a log database. The logs are exported from the ESS to an FTP server. The Log 
Collector imports the logs from the FTP server and stores them in an SQL database. The 
Log Analyser fetches data from the SQL server to display in the Log Analyser GUI.

The FTP server and the SQL server can be run either on the same PC as the Log Analyser 
application or as distributed services on the network.

ESS Enhanced System Service:
Unite module that handles centralised number planning, 
remote connection, system supervision, fault handling, 
group handling, message routing, centralised logging, 
activity logging, and user access administration.

FTP File Transfer Protocol

GUI Graphical User Interface

IMS Integrated Message Server:
Unite module that enables messaging to and from the 
connected cordless telephone system

SQL Structured Query Language
A programming language used to store and retrieve data 
in databases.

Figure 1. 
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2.1 Requirements

2.1.1 Hardware

• Unite System

- ESS set up to send logs to the server
- Unite modules set up to send logs to the ESS

• Server

- 1 gigahertz (GHz) processor
- 1 gigabyte (GB) of RAM
- TCP/IP network connection
- Windows XP®, Service Pack 2 (SP2).

• Client Computer

- 1 gigahertz (GHz) processor
- 512 megabytes (MB) of RAM
- TCP/IP network connection (if SQL database runs on a remote server)
- Windows XP®, Service Pack 2 (SP2) or Windows Vista.

2.1.2 Software

Note: The required Microsoft software can be downloaded from Microsoft’s homepage. 
The installation of Microsoft software is beyond the scope of this document.

• ESS version 2.11 or later

- Licence for creating logs (ESS-LLT)
• Server

- Microsoft SQL Server 2005 or Microsoft SQL Server 2005 Express Edition
- Microsoft Windows Installer 3.1
- Microsoft Core XML Services (MSXML) 6.0

• Client

- Microsoft .NET Framework 2.0
- Microsoft Office 2003 Web Component

2.1.3 Translation

• Microsoft Visual Studio Express

2.2 Recommended Working Flow

It is recommended to install and operate the Unite Log Analyser in the following order:

2.2.1 Service Technician

1 Install the software listed in 2.1 Requirements on page 5.

2 Install and configure the Unite Log Database, Unite Log Collector, and Unite Log 
Analyser according to the instructions in 4 Installation and Configuration on page 6.

2.2.2 Administrator

1 Start and run the Log Analyser according to the instructions in chapter 6 
Administrator Mode Operating Instructions on page 16.

2 Save one or more analyses for use in User mode according to chapter 6.6 Create a 
Template on page 28.
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2.2.3 User

Start and run the Log Analyser according to the instructions in chapter 7 User Mode 
Operating Instructions on page 28.

3 Unite Log Analyser and IT Security

It is recommended that the security level is in accordance with related IT solutions.

For more information about IT security, see also System Planning Unite, TD 92258GB.

All communication between the different parts of the Unite Log Analyser application, that 
is, between the ESS and the FTP server, between the FTP server and the Log Collector, and 
between the SQL server and the Log Analyser client, is unencrypted. Because of this no 
parts of the application should be run on a public network.

4 Installation and Configuration

There are several possible installation scenarios for the Unite Log Analyser:

• The Microsoft SQL Server, the Unite Log Collector, and the Unite Log Analyser 
Administrator client are installed on the same computer.

• The Microsoft SQL Server and the Unite Log Collector are installed on a server, while 
the Unite Log Collector Administrator client is installed on one or more separate PCs.

• The Microsoft SQL Server and the Unite Log Collector are each installed on a separate 
server, while the Unite Log Collector Administrator client is installed on one or more 
separate PCs.

In addition, the Unite Log Analyser User client can be installed on one or more separate 
PCs. In the installation instructions below it is noted when these different scenarios have 
to be taken into account.

It is not possible to run the installation kits for the Unite Log Analyser Administrator client 
and the Unite Log Analyser User client on the same computer. It is, however, possible to 
run both clients on a computer with the Unite Log Analyser administrator client installed. 
See 4.6.3 Setup Shortcut to Unite Log Analyser User client on page 12 for instructions.

Note: You need to be logged on as a user with administrator permissions to install and 
configure the Unite Log Analyser and associated programs.

4.1 Install the Unite Log Database

1 Open the Database.Install folder.

2 Double click setup.exe to start the Unite Log Database installation. The installation 
program will guide you through the installation process.

When asked for a password, choose the appropriate authentication mode; this 
depends on the installation of the SQL Server and enter username and password (if 
necessary).
2007-05-31/ Ver. A 6
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4.2 Verify the Unite Log Database Installation and Configuration

Open the Analyser database in your preferred database management application, for 
example Microsoft SQL Server Management Studio Express. After a successful installation 
the Analyzer database should have been created. See figure 2 on page 7 for how this will 
look in Microsoft SQL Server Management Studio Express.

Figure 2. The Analyzer database in Microsoft SQL Server Management Studio 
Express.

4.3 Remove the Unite Log Database Package

The Unite Log Database installation package is only used to create the database. After the 
database has been created this package can be uninstalled. When uninstalling the Unite 
Log Database package you will be given the option to also uninstall the database itself. If 
you choose not to do this but later decide to remove the database you must manually 
drop it from the SQL Server using Microsoft SQL Server Management Studio Express or 
other appropriate software.

4.4 Install the Unite Log Collector

1 Open the Collector.Install folder.

2 Double-click setup.exe to start the Unite Log Collector installation. The installation 
program will guide you through the installation process.

If prompted to update Microsoft .NET, follow the program’s advice to do so.

Figure 2. 
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4.4.1 Set Log Collector Permissions

The Collector must have permissions to access both the directory where the uploaded files 
reside and the database into which the files shall be imported.The permissions which are 
granted to the collector depends on which account that is used to start the service.

If the directory, database and collector service run on a computer on the network, follow 
the instructions below. If everything is run locally on one PC, continue to 4.4.2 Configure 
the Unite Log Collector on page 8

1 In the Start menu, select Control Panel>Administrative Tools>Services

2 In the Services window, double-click Ascom Unite Log Collector.

3 In the Ascom Unite Log Collector Properties window, select the "Log On" tab.

4 Select the "This account:" radio button and enter the user which should run the 
service. Alternatively, select the "Local System Account" radio button.

5 Click "OK".

You need to give the selected user permission to read and write data to the Analyser 
database. How this shall be done is depending on you server environment and is outside 
the scope of this manual.

4.4.2 Configure the Unite Log Collector

All configurable settings for the Unite Log Collector are stored in the XML file  
C:\Program Files\Ascom\Unite Log Collector\Ascom.Analyser.Collector.exe.config. Some of 
the values in the file must be configured to suit your configuration.

Note: The Unite Log Collector needs to be restarted for changes to take effect.

Set the Unite Log Collector Service Dependency

The Collector service is installed with a dependency towards the instance of SQL SERVER 
named SQLEXPRESS. This means that when rebooting the computer the Collector will wait 
to auto start until the SQLEXPRESS instance is online.

If the SQL Server is installed on a different computer or on the same computer but with a 
different instance name the dependency will be ignored.

If the SQL Server instance has a different name (other than SQLEXPRESS) you need to 
change this dependency if you want the collector to start automatically during reboot. 
This can only be done by changing the appropriate key in the Windows registry.

1 In the Start menu, Select Run. Type "regedit" and click "OK".

2 In the left pane of the Register Editor, select 
My Computer>HKEY_LOCAL_MACHINE>SYSTEM>CurrentControlSet>Services>
Collector.

3 In the right pane, double-click DependOnService.

4 In the Edit Multi-string window, type the name of the SQL Server instance.

5 Click "OK".
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Figure 3. The DependOnService key in the Windows Registry Editor.

Edit the Unite Log Collector Configuration File

Note: You are not allowed to change any other values than the ones listed in figure 4 on 
page 10. Of these, the ones you would most likely want to change to suit your installation 
are Directory, Interval, Connection String and Archive Directory. 

1 Open C:\Program Files\Ascom\Unite Log Collector\
Ascom.Analyser.Collector.exe.config in a text editor or XML editor.

2 Edit the appropriate parameters.

3 Save the file and exit the editor.

Figure 3. 
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Figure 4. Editable parameters in the Ascom.Analyser.Collector.exe.config file

4.5 Verify the Log Collector Installation and Configuration

1 Open C:\Program Files\Ascom\Unite Log Collector\
Ascom.Analyser.Collector.exe.config for editing in a text editor or XML editor.

2 Set the Debug parameter to "True".

3 Save the file and exit the editor.

4 In the Start menu, select Control Panel>Administrative Tools>Services

5 In the Services window, right-click Ascom Unite Log Collector and select "Start".

6 If no error dialogue appears, the Log Collector is working correctly. If an error 
dialogue appears, see 8.2 Troubleshoot the Unite Log Collector on page 39.

If the Log Collector is working correctly, open 
C:\Program Files\Ascom\Unite Log Collector\Ascom.Analyser.Collector.exe.config

4.6 Install the Unite Log Analyser Administrator Client

4.6.1 Install the Unite Log Analyser

1 Open the Analyser.Admin.Install folder.

2 Double click setup.exe to start the Unite Log Analyser installation. The installation 
program will guide you through the installation process.

Parameter Default Value Description

Directory c:\ess The directory to be 
monitored

File Type .xml The file type to look for in 
the monitored directory

Interval 5 The interval in minutes 
between checks for new files

Archive True Turns on or off archiving of 
imported files. Can be set to 
"True" or "False"

ArchiveDirectory c:\archive Path to the directory where 
archived files will be stored

Debug False Turn on or off extensive 
logging to the eventlog

ErrorDirectory <no value> Not used.

Culture <no value> Defines which language to 
use. If left empty English will 
be used.

ConnectionString connectionString="Data
Source=.\SQLExpress;Initial
Catalog=Analyser;Integrated
Security=True;"

The string used to connect 
to the database
2007-05-31/ Ver. A 10
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4.6.2 Configure the Unite Log Analyser

All configurable settings for the Unite Log Analyser are stored in the XML file  
C:\Program Files\Ascom\Unite Log Analyser\Ascom.Analyser.Collector.exe.config. Some of 
the values in the file may need to be configured to suit your configuration; most important 
is ConnectionString.

Edit the Unite Log Analyser Configuration File

Note: You should only change the values described in figure 5 on page 11.

1 Open C:\Program Files\Ascom\Unite Log Analyser\
Ascom.Analyser.Analyser.exe.config in a text editor or XML editor.

2 Edit the parameter values you wish to change.

3 Save the file and exit the editor.

Figure 5. Editable parameters in the Ascom.Analyser.Analyser.exe.config file

Parameter Default Value Description

ConnectionString DataSource=
(local)\SQLEXPRESS;
InitialCatalog=
Analyser;IntegratedSecurity=
SSPI;AsynchronousProcessin
g=
true;

The string used to connect 
to the database

AnalysisSchemaFile Analysis.xsd Name and path of the XML 
schema file used to verify an 
analysis file.

ConfigurationSchema
File

Analyser.xsd Name and path of the XML 
schema file used to verify 
the configuration file.

ConfigurationFile Analyser.xml Name and path of the
XML configuration file.

MaxChartColumns 100 Defines the maximum 
number of columns shown 
in the AnalysisOverTime 
analysis.

Culture <no value> Defines which language to 
use. If left empty English will 
be used.

AdministratorMode True Not used.

ApplicationSplitPosition 155 Defines the position of the 
application splitter.

FileOpenDir Application directory Defines the folder the file 
open dialogue starts in.
2007-05-31/ Ver. A 11
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4.6.3 Setup Shortcut to Unite Log Analyser User client

The Unite Log Analyser administrator client can be started in user mode. To accomplish 
this, create a shortcut to the Ascom.Analyser.Analyser.exe file. The default installation 
folder is C:\Program Files\Ascom\Unite Log Analyser\Ascom.Analyser.Analyser.exe.

4.7 Install the Unite Log Analyser User Client

4.7.1 Install the Unite Log Analyser

1 Open the Analyser.Install folder.

2 Double click setup.exe to start the Unite Log Analyser installation. The installation 
program will guide you through the installation process.

4.7.2 Configure the Unite Log Analyser

Follow the instructions in 4.6.2 Configure the Unite Log Analyser on page 11.

4.8 Verify the Unite Log Analyser Installation and Configuration

1 in the Start menu, select All Programs>Ascom>Unite Log Analyser.

2 Analyse a log file according to the instructions in 6.2 Analyse a Log File on page 16.

5 Translation

Note: This chapter describes a procedure that requires some programming skills. It is only 
necessary to do once for each Log Analyser software version and language.

The Unite Log Analyser by default uses English for the GUI. This can be overridden by 
entering a custom language in the application configuration file. The process of changing 
language in the application is straightforward but requires a few steps. Language 
dependant texts exist in the application forms and in a resource file. The language has to 
be changed in both locations.

Unfortunately WinRes cannot be used together with this project. Therefore it is here 
described how to change the language with Microsoft Visual Studio 2005 or Visual Studio 
Express.

There are two types of components in the source that need to be changed:

• Resource strings

• Windows forms

5.1 Install the Unite Log Analyser Source

1 Open the Analyser.Source.Install folder.

2 Double click setup.exe to start the Unite Log Analyser Source installation. The 
installation program will guide you through the installation process.
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5.2 Install Microsoft Visual Studio Express C#

Microsoft Visual Studio Express C# is available on Microsoft’s homepage at:
http://www.microsoft.com/downloads/.

The installation of Microsoft Visual Studio Express is beyond the scope of this document.

5.3 Windows Forms

As default all resources will be compiled into the main assembly of the application. To 
support a different language you will have to create a satellite assembly. This can be done 
with SDK tools or with Visual Studio.

Since we need to use Visual Studio to change the form resources we will use Visual Studio 
to describe how to create the satellite assembly.

All windows forms for the Log Analyser application are contained in the WindowsUI 
project and each window form contains a separate resource file.

Figure 6. Window resource files.

To localize a form resource you need to perform two steps.

First you must set the Localizable property of the form to True

Figure 7. The localizable property set to True.

Secondly you need to change the Language to your language of choice; in this example it 
will be named MainForm.sv-SE.resx (see figure 9 below).

Figure 8. Language set to Swedish.

Figure 4. 

Figure 5. 

Figure 6. 
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Once you save the project Visual Studio will create a new resource file for you, in this 
example it will be named MainForm.sv-SE.resx (see figure 9). This resource file will only 
contain resources that you actually have changed.

Figure 9. New resource file created by Visual Studio.

If you change any name or size of a control this will be saved to the new localized 
resource.

Here is an example of the main form with Swedish texts.

Figure 10. The main form with Swedish texts.

5.4 Application string resources

In the Ascom.Analyser.WindowsUI project there is a file called Resources.resx which 
contains resources for the project. Currently it contains only strings but it can contain 
other resources.

To create a new resource file use copy and paste on the Resources.resx file. The new file 
shall be named similarly to the localized form in the previous chapter. If using swedish as in 
the previous example, use Resources.sv-SE.resx as the new filename.

If you build the project all the form resources and the application string resources will be 
built into a single satellite assembly. Since the default language is built into the default 
assembly it will always be used as a fallback if the satellite assembly for a specific language 
is missing or if you have some texts which is not included in the satellite assembly.

Figure 7. 

Figure 8. 

Figure 9. 

Figure 10. 
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5.5 Limitations with C# Express

When working with the project in Visual C# Express there is a problem with the 
AxInterop.OWC11 assembly. If the solution is rebuilt, this file is removed and not re-
created automatically as it is in Visual Studio 2005, the work around for this is to copy the 
file manually. A copy of the file is available in 
<Source folder>\WindowsUI\AxInterop.OWC11.dll. Just copy this file to 
<Source folder>\WindowsUI\obj\Release and build the project again (don't rebuild as this 
will remove the file again, just build)

5.6 Applying a translation

A translation is added to an already existing Log Analyser client by building it according to 
the instructions in this chapter. Visual Studio will create a subdirectory containing the 
satellite assembly in the output directory. Copy this subdirectory with all its contents to the 
directory where the application is installed.

To use the new language in the application modify the Ascom.Analyser.exe.config file and 
set the Culture attribute to the same name as the directory. In our example this will look as 
in the example below:

<setting name="Culture" serializeAs="String">

           <value>sv-SE</value>

</setting>

5.7 Creating a distribution package

The complete Unite Log Analyser distribution consists of four parts:

• Unite Log Analyser Source

• Unite Log Analyser

• Unite Log Collector

• Unite Log Database

Depending on the needs of the customer, one or more of these parts may be included in a 
package to be distributed to the customer. To make a distribution package, decide which 
parts the customer needs and combine them in a ZIP file.

Figure 11. 
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6 Administrator Mode Operating Instructions

6.1 Start the Unite Log Analyser in Administrator Mode

The Unite Log Analyser can be used in two modes, Administrator and User. When in User 
mode, only the Selection parameters checked in Administrator mode as described in 6.3 
Set the Selection to Be Visible in User Mode on page 24 can be modified.

In the Start menu, select All Programs>Ascom>Unite Log Analyser>Analyser (Admin 
mode).

6.2 Analyse a Log File

The Unite Log Analyser main window consists of two panes, the Selection pane and the 
Presentation pane, as shown in figure 11 on page 16. The Presentation pane shows the 
analysis of the log file as a bar graph if the Analysis over Time, the Mean traffic, or the 
Peak traffic templates are used, or as data in table format if the Data view template is 
used.

There are two tabs in the Selection pane, the Search tab and the Presentation tab. The 
choices made in the Search tab determines which information is fetched from the 
database, while the choices made in the Presentation tab determines how the information 
is presented.

Figure 11. The Unite Log Analyser main window.

6.2.1 Activities over Time Analysis

1 Click "New" in the toolbar, or select File>New.

Figure 12. 
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2 In the New dialogue box, select "Activities over time" from the Select analysis 
template drop-down list.

3 Click "OK".

The Selection pane and an empty Analysis pane are opened. In the Selection pane, the 
Search tab is active.

Set the Interval to Analyse

1 In the Time frame, select the start date for the analysis in the drop-down list in the 
Begin column.

2 Enter the start time for the analysis in the Time text box in the Begin column. The 
time must be entered in the format HH:MM:SS.

3 Select the end date for the analysis in the drop-down list in the End column.

4 Enter the end time for the analysis in the Time text box in the End column. The time 
must be entered in the format HH:MM:SS.

Filter Priorities

In the Priorities frame, select the check boxes corresponding to the priorities you wish to 
view:

• Alarm

• High

• Normal

• Low

• No priority

To select all priorities, right-click anywhere in the list and select "Select all".

To deselect all priorities, right-click anywhere in the list and select "Deselect all".

By default, all priorities are selected. If no check boxes are selected, this is interpreted as all 
check boxes being selected.

Filter Activities

In the Activities frame, select the check boxes corresponding to the activity groups you 
wish to view:

• Messages

• Personal Alarms

• Data from User

• Input/Output

• Location Data

• Absence Information

• System Events

• Customised Log

• Special Activities

To see which activities are included in each group, point the mouse at an item in the list. A 
tooltip appears with a list of the included activities.

To select all activities, right-click in the list and Select "Select All" in the pop-up menu that 
appears.
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To deselect all activities, right-click in the list and Select "Deselect All" in the pop-up menu 
that appears.

By default, all activities are selected.

Select Origin

In the Origin frame, enter the desired origin in the text field. The "*" wildcard is allowed.

Select Destination

In the Selection frame, enter the desired value in the text field. The "*" wildcard is 
allowed.

Enter Details to Search for

It is possible to only view activities containing a specific value in the details.

In the Details frame, enter the value, or part of the value, you wish to search for in the text 
field.

Set Period

The Presentation tab is used to set how the data for the selected interval is presented. The 
data can be viewed as a separate bar in the graph for each year, quarter, month, week, 
day, hour, or minute.

1 In the Selection pane, select the Presentation tab.

2 Select the desired period from the Period drop-down-list.

View the Analysis

1 Click the "Apply selection" button in the toolbar.

The progress bar at the bottom of the indicates that the Unite Log Analyser is 
fetching data from the log database.

2 A bar graph showing the data appears in the Analysis pane.

To view period details, place the mouse cursor over a bar in the graph. A tooltip shows the 
following information about the period covered by the bar:

• The minute, hour, date, week number, month, or year of the period covered by the bar, 
depending on the selected period division.

• The number of events in the period.
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Figure 12. Activities over time analysis.

6.2.2 Data View Analysis

1 Click “New” in the toolbar, or select File>New.

2 In the New dialogue box, select "Data view" from the Select analysis template 
drop-down list.

3 Click "OK".

The Selection pane and an empty Analysis pane are opened. In the Selection pane, the 
Search tab is active.

Set the Interval to Analyse

See  Set the Interval to Analyse on page 17.

Filter Priorities

See  Filter Priorities on page 17.

Filter Activities

See  Filter Activities on page 17

Select Origin

See  Select Origin on page 18

Figure 13. 
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Select Destination

See Select Destination on page 18.

Enter Details to Search for

See  Enter Details to Search for on page 18.

View the Analysis

1 Click "Fetch data" in the toolbar.

The progress bar at the bottom of the indicates that the Unite Log Analyser is 
fetching data from the log database.

2 The data will appear in the Analysis pane as shown in figure 13 on page 20.

Figure 13. Data View analysis.

The data is shown in three frames in the Analysis pane: the Activities table, the Related 
Activities table, and the Details text field. The Activities table shows all activities according 
to the selection. The Related Activities table shows all activities related to the currently 
selected activity in the Activities table. The Details text field shows the details for the 
currently selected entry in the Activities table or the Related Activities table.

To hide or unhide the Related Activities table, click the Related Activities button in the 
toolbar.

To hide or unhide the Details text field, click the Details button in the toolbar.

3 In the Selection frame, select the Presentation tab.

Figure 14. 
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4 In the Dataview frame, select the check boxes corresponding to the columns that 
should be shown in the Activities table and the Related Activities table.

The following columns can be shown:

• Date
• Time
• Origin
• Destination
• Activity
• Information
• Priority
• Type
By default, all check boxes are selected.

6.2.3 Mean Traffic Analysis

1 Click "New" in the toolbar, or select File>New.

2 In the New dialogue box, select "Mean traffic" from the Select analysis template 
drop-down list.

3 Click "OK".

The Selection pane and an empty Analysis pane are opened. In the Selection pane, the 
Search tab is active.

Set the Interval to Analyse

See  Set the Interval to Analyse on page 17.

Filter Priorities

See  Filter Priorities on page 17.

Filter Activities

See  Filter Activities on page 17

Select Origin

See  Select Origin on page 18.

Select Destination

See  Select Destination on page 18.

Enter Details to Search for

See  Enter Details to Search for on page 18.

Select Type of Analysis

The Presentation tab is used to set how the data for the selected interval is presented. The 
data can be viewed as a separate bar in the graph for each month of year, day of week or 
hour of day.

1 In the Selection pane, select the Presentation tab.

2 Select the desired type of presentation from the Type drop-down-list.
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View the Analysis

1 Click the "Apply selection" button in the toolbar.

The progress bar at the bottom of the indicates that the Unite Log Analyser is 
fetching data from the log database.

2 A bar graph showing the data appears in the Analysis pane.

To view period details, place the mouse cursor over a bar in the graph. A tooltip shows the 
following information about the period covered by the bar:

• The hour of day, day of week, or month of year covered by the bar, depending on the 
selected period division.

• The mean number of events in the period.

Figure 14. Mean traffic analysis.

6.2.4 Peak Traffic Analysis

1 Click "New" in the toolbar, or select File>New.

2 In the New dialogue box, select "Peak traffic" from the Select analysis template 
drop-down list.

3 Click "OK".

The Selection pane and an empty Analysis pane are opened. In the Selection pane, the 
Search tab is active.

Set the Interval to Analyse

See Set the Interval to Analyse on page 17.

Filter Priorities

See Filter Priorities on page 17.

Figure 15. 
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Filter Activities

See Filter Activities on page 17.

Select Origin

See Select Origin on page 18.

Select Destination

See Select Destination on page 18.

Enter Details to Search for

See Enter Details to Search for on page 18.

Set Period

See  Set Period on page 18.

View the Analysis

1 Click the "Apply selection" button in the toolbar.

The progress bar at the bottom of the window indicates that the Unite Log Analyser 
is fetching data from the log database.

2 A bar graph showing the data appears in the Analysis pane.

To view period details, place the mouse cursor over a bar in the graph. A tooltip shows the 
following information about the period covered by the bar:

• The minute, hour, date, week number, month, or year of the period covered by the bar, 
depending on the selected period division.

• The number of events in the period.
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Figure 15. Peak traffic analysis.

6.3 Set the Selection to Be Visible in User Mode

In the Editable by user frame, select the check boxes for the Selections you wish to be 
visible in User mode.

See figure 16 on page 25 and figure 17 on page 26 for an example of how this will look in 
the GUI.

Figure 16. 
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Figure 16. Example of Selections set in Administrator mode.

Figure 17. 
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Figure 17. In User mode, only the Selections set in Administrator mode are 
accessible.

6.4 Activate/Deactivate User Mode

The Unite Log Analyser (Admin mode) can be switched to work in User mode. When in 
User mode, only the Selection parameters selected in Administrator mode as described in 
6.3 Set the Selection to Be Visible in User Mode on page 24 can be modified. This is useful 
for making sure that a template works as intended.

6.4.1 Activate User Mode

In the toolbar, click "Activate user mode".

6.4.2 Deactivate User Mode

In the toolbar, click "Deactivate user mode".

6.5 Create a Report

It is possible to create a report for use in an external program, for example in a Microsoft 
PowerPoint presentation or Microsoft Word document.

6.5.1 Create an Activities over Time, a Mean Traffic, or a Peak Traffic Report

An Activities over time, a Mean Traffic, or a Peak Traffic analysis is exported as a picture.

1 Right-click in the Analysis pane.

2 Select "Copy".

Figure 18. 
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3 Switch to the program where you wish to use the report.

4 Use the program’s paste function to insert the report.

6.5.2 Create a Data View Report

Data from the Data view analysis is exported in different formats, depending on which 
part of the analysis is exported, as shown in figure 18 on page 27.

Figure 18. Format of data exported from a Data view analysis.

Copy Activities Data

1 Select the rows you wish to export from the Activities table. Select multiple rows by 
pressing Ctrl and clicking on each of the desired rows, by pressing shift and clicking 
on the first and last of the desired rows, or by right clicking in the table and 
selecting the "Select All" option.

2 Right-click on the Activities table.

3 Select "Copy".

4 Switch to the program where you wish to use the report.

5 Use the program’s paste function to insert the report.

Copy Related Activities Data

1 Select the rows you wish to export from the Related Activities table. Select multiple 
rows by pressing Ctrl and clicking on each of the desired rows, by pressing shift and 
clicking on the first and last of the desired rows, or by right clicking in the table and 
selecting the "Select All" option.

2 Right-click on the Related Activities table.

3 Select "Copy".

4 Switch to the program where you wish to use the report.

5 Use the program’s paste function to insert the report.

Copy Details

1 Click the desired row in the Activities table.

2 Click the desired row in the Related Activities table.

3 Right-click in the Details text field. All text in the field is selected. Alternatively, click 
and drag to select the text you wish to export, and then right-click in the Details 
text field.

4 Select "Copy"

5 Switch to the program where you wish to use the report.

6 Use the program’s paste function to insert the report.

Data Format

Activities Table

Related Activities Table

Details Text
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6.6 Create a Template

1 In the menu, select File>Properties.

The Properties window opens

2 In the Description text field, type a description of the template.

3 Click "OK".

4 Use the "Save" button in the toolbar or select File>Save in the menu to save the 
template.

6.7 Open a Template

Click "Open" in the toolbar or select File>Load in the menu to load a saved template.

6.8 Select Panes to be Viewed

The default setting is to show all panes. It is possible to select which panes to be viewed 
from the View menu.

7 User Mode Operating Instructions

7.1 Start the Unite Log Analyser

In the Start menu, select All Programs>Ascom>Unite Log Analyser (User mode).

7.2 Analyse a Log File

Note: When using the Unite Log Analyser in User mode, only the Selection parameters 
selected for the current analysis in Administrator mode will be visible.

The Unite Log Analyser main window consists of two panes, the Selection pane and the 
Presentation pane, as shown in figure 19 on page 29. The Presentation pane shows the 
analysis of the log file as a bar graph if the Analysis over Time, the Mean traffic, or the 
Peak traffic templates are used, or as data in table format if the Data view template is 
used.

There are two tabs in the Selection pane, the Search tab and the Presentation tab. The 
choices made in the Search tab determines which information is fetched from the 
database, while the choices made in the Presentation tab determines how the information 
is presented.
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Figure 19. The Log Analyser main window.

View Analysis Properties

1 In the menu, select File>Properties.

The Properties window appears, with information about the analysis in the 
Description text field.

2 Close the Properties window by clicking on the "Close" button.

7.2.1 View Activities over Time

1 Use the "Open" button in the toolbar or select File>Open in the menu to load a 
saved Activities over Time analysis.

2 Click "OK".

The Selection pane and an empty Analysis pane are opened. In the Selection pane, the 
Search tab is active.

Set the Interval to Analyse

1 In the Time frame, select the start date for the analysis in the drop-down list in the 
Begin column.

2 Enter the start time for the analysis in the Time text box in the Begin column. The 
time must be entered in the format HH:MM:SS.

3 Select the end date for the analysis in the drop-down list in the End column.

4 Enter the end time for the analysis in the Time text box in the End column. The time 
must be entered in the format HH:MM:SS.

Figure 19. 
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Filter Priorities

In the Priorities frame, select the check boxes corresponding to the priorities you wish to 
view:

• Alarm

• High

• Normal

• Low

• No priority

To select all priorities, right-click anywhere in the list and select "Select all".

To deselect all priorities, right-click anywhere in the list and select "Deselect all".

By default, all priorities are selected. If no check boxes are selected, this is interpreted as all 
check boxes being selected.

Filter Activities

In the Activities frame, select the check boxes corresponding to the priorities you wish to 
view:

• Messages

• Personal Alarms

• Data from User

• Input/Output

• Location Data

• Absence Information

• System Events

• Customised Log

• Special Activities

To see which activities are included in each group, point the mouse at an item in the list. A 
tooltip appears with a list of the included activities.

To select all activities, right-click in the list and Select "Select All" in the pop-up menu that 
appears.

To deselect all activities, right-click in the list and Select "Deselect All" in the pop-up menu 
that appears.

By default, all activities are selected.

Select Origin

In the Origin frame, enter the desired origin in the text field. The "*" wildcard is allowed.

Select Destination

In the Selection frame, enter the desired value in the text field. The "*" wildcard is 
allowed.

Enter Details to Search for

It is possible to only view activities containing a specific value in the details.
2007-05-31/ Ver. A 30



TD TD92421GB
Installation and Operation Manual
Unite Log Analyzer
In the Details frame, enter the value, or part of the value, you wish to search for in the text 
field.

Set Period

The Presentation tab is used to set how the data for the selected interval is presented. The 
data can be viewed as a separate bar in the graph for each year, quarter, month, week, 
day, hour, or minute.

1 In the Selection pane, select the Presentation tab.

2 Select the desired period from the Period drop-down-list.

View the Analysis

1 Click the "Apply selection" button in the toolbar.

The progress bar at the bottom of the indicates that the Unite Log Analyser is 
fetching data from the log database.

2 A bar graph showing the data appears in the Analysis pane.

To view period details, place the mouse cursor over a bar in the graph. A tooltip shows the 
following information about the period covered by the bar:

• The minute, hour, date, week number, month, or year of the period covered by the bar, 
depending on the selected period division.

• The number of events in the period.

Figure 20. View period details.

7.2.2 Data View Analysis

1 Use the "Open" button in the toolbar or select File>Open in the menu to load a 
saved Data View analysis.

Figure 20. 
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2 Click "OK".

The Selection pane and an empty Analysis pane are opened. In the Selection pane, the 
Search tab is active.

Set the Interval to Analyse

See Set the Interval to Analyse on page 29.

Filter Priorities

See  Filter Priorities on page 30.

Filter Activities

See Filter Activities on page 30.

Select Origin

See  Select Origin on page 30

Select Destination

See Select Destination on page 30.

Enter Details to Search for

See Enter Details to Search for on page 30.

View the Analysis

1 Click "Fetch data" in the toolbar.

2 The progress bar at the bottom of the window indicates that the Unite Log Analyser 
is fetching data from the log database.

3 The data will appear in the Analysis pane as shown in figure 21 on page 33.
2007-05-31/ Ver. A 32



TD TD92421GB
Installation and Operation Manual
Unite Log Analyzer
Figure 21. Data view analysis.

The data is shown in three frames in the Analysis pane: the Activities table, the Related 
Activities table, and the Details text field. The Activities table shows all activities according 
to the selection. The Related Activities table shows all activities related to the currently 
selected activity in the Activities table. The Details text field shows the details for the 
currently selected entry in the Activities table or the Related Activities table.

To hide or unhide the Related Activities table, click the Related Activities button in the 
toolbar.

To hide or unhide the Details text field, click the Details button in the toolbar.

4 In the Selection frame, select the Presentation tab.

5 In the Dataview frame, select the check boxes corresponding to the columns that 
should be shown in the Activities table and the Related Activities table.

The following columns can be shown:

• Date
• Time
• Origin
• Destination
• Activity
• Information
• Priority
• Type
By default, all check boxes are selected.

7.2.3 Mean Traffic Analysis

1 Use the "Open" button in the toolbar or select File>Open in the menu to load a 
saved Mean Traffic analysis.

Figure 21. 
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2 Click "OK".

The Selection pane and an empty Analysis pane are opened. In the Selection pane, the 
Search tab is active.

Set the Interval to Analyse

See Set the Interval to Analyse on page 29.

Filter Priorities

See Filter Priorities on page 30.

Filter Activities

See Filter Activities on page 30.

Select Origin

See Select Origin on page 30.

Select Destination

See Select Destination on page 30.

Enter Details to Search for

See Enter Details to Search for on page 30.

Select Type of Analysis

The Presentation tab is used to set how the data for the selected interval is presented. The 
data can be viewed as a separate bar in the graph for each month of year, day of week or 
hour of day.

1 In the Selection pane, select the Presentation tab.

2 Select the desired type of presentation from the Type drop-down-list.

View the Analysis

1 Click the "Apply selection" button in the toolbar.

The progress bar at the bottom of the indicates that the Unite Log Analyser is 
fetching data from the log database.

2 A bar graph showing the data appears in the Analysis pane.

To view period details, place the mouse cursor over a bar in the graph. A tooltip shows the 
following information about the period covered by the bar:

• The hour of day, day of week, or month of year covered by the bar, depending on the 
selected period division.

• The mean number of events in the period.
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Figure 22. Mean traffic analysis.

7.2.4 Peak Traffic Analysis

1 Use the "Open" button in the toolbar or select File>Open in the menu to load a 
saved Peak Traffic analysis.

2 Click "OK".

The Selection pane and an empty Analysis pane are opened. In the Selection pane, the 
Search tab is active.

Set the Interval to Analyse

See Set the Interval to Analyse on page 29.

Filter Priorities

See Filter Priorities on page 30.

Filter Activities

See Filter Activities on page 30.

Select Origin

See Select Origin on page 30.

Select Destination

See Select Destination on page 30.

Figure 22. 
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Enter Details to Search for

See Enter Details to Search for on page 30.

Set Period

See Set Period on page 31.

View the Analysis

1 Click the "Apply selection" button in the toolbar.

The progress bar at the bottom of the window indicates that the Unite Log Analyser 
is fetching data from the log database.

2 A bar graph showing the data appears in the Analysis pane.

To view period details, place the mouse cursor over a bar in the graph. A tooltip shows the 
following information about the period covered by the bar:

• The minute, hour, date, week number, month, or year of the period covered by the bar, 
depending on the selected period division.

• The number of events in the period.

Figure 23. Peak traffic analysis.

7.3 Export an Analysis

It is possible to export an analysis for use in an external program, for example in a 
Microsoft PowerPoint presentation or Microsoft Word document.

Figure 23. 
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7.3.1 Export an Activities over Time, a Mean Traffic, or a Peak Traffic Analysis

An Activities over time, a Mean Traffic, and a Peak Traffic analysis is exported as a picture. 

1 Right-click in the Analysis pane.

2 Select "Copy".

3 Switch to the program you wish to use the analysis in.

4 Use the paste function in the program to insert the analysis in.

7.3.2 Export a Data View Analysis

Data from the Data view analysis is exported in different formats, depending on which 
part of the analysis is exported, as shown in figure 18 on page 27.

Figure 24. Format of data exported from a Data view analysis.

Export Activities Data

1 Select the rows you wish to export from the Activities table. Select multiple rows by 
pressing Ctrl and clicking on each of the desired rows, by pressing shift and clicking 
on the first and last of the desired rows, or by right clicking in the table and 
selecting the "Select All" option.

2 Right-click on the Activities table.

3 Select "Copy".

4 Open the program you wish to use the analysis in.

5 Use the paste function in the program to insert the analysis.

Export Related Activities Data

1 Select the rows you wish to export from the Related Activities table. Select multiple 
rows by pressing Ctrl and clicking on each of the desired rows, by pressing shift and 
clicking on the first and last of the desired rows, or by right clicking in the table and 
selecting the "Select All" option.

2 Right-click on the Related Activities table.

3 Select "Copy".

4 Open the program you wish to use the data in.

5 Use the paste function in the program to insert the data in.

Export Details

1 Click the desired row in the Activities table.

2 Click the desired row in the Related Activities table.

Data Format

Activities Table

Related Activities Table

Details Text
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3 Right-click in the Details text field. All text in the field is selected. Alternatively, click 
and drag to select the text you wish to export, and then right-click in the Details 
text field.

4 Select "Copy"

5 Open the program you wish to use the data in.

6 Use the paste function in the program to insert the data in.

7.4 Select Panes to be Viewed

The default setting is to show both panes.

Turn the Selection pane on or off

In the toolbar, click the "Selection" button.

Turn the Analysis pane on or off

In the toolbar, click the "Analysis" button.

8 Troubleshooting

8.1 Troubleshoot the Unite Log Database

8.1.1 Unite Log Database Cannot Connect to Database Server during Installation

If the Unite Log cannot connect to the Microsoft SQL server during installation, the error 
dialogue box in figure 25 on page 38 appears.

Figure 25. 

This means that either the SQL server is unavailable or that you have provided an incorrect 
username or password.

Make Sure the Microsoft SQL Server Is Available

1 In the Start menu, select Control Panel>Administrative Tools>Add or Remove 
Programs.

If Microsoft SQL Server 2005 is missing from the list of installed programs, install 
Microsoft SQL Server 2005.

Figure 24. 
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2 In the Start menu, select Control Panel>Administrative Tools>Services

Make sure that the SQL Server service is running. If it is not running, continue to  
Make Sure the Correct Username and Password Have Been Provided on page 39.

Make Sure the Correct Username and Password Have Been Provided

1 In the Services window, right-click SQL Server (SQLEXPRESS).

2 Select "Start"

If the SQL Server service does not start, continue with the steps below.

3 Double-click the SQL Server (SQLEXPRESS).

4 In the Log On tab, click the "This account:" radio button.

5 Enter the correct account and password.

6 Click "OK".

7 In the Services window, right-click SQL Server (SQLEXPRESS).

8 Select "Start".

The SQL Server service should now be started.

8.2 Troubleshoot the Unite Log Collector

8.2.1 The Collector Service Fails to Start

If the Collector service fails to start, a dialogue box with the message "The Ascom Unite 
Log Collector service on Local Computer started and then stopped. Some services stop 
automatically if they have no work to do, for example, the Performance Logs and Alert 
service."

1 In the Start menu, select Control Panel>Administrative Tools>Event Viewer.

2 In the Event Viewer window, click Application.

Look for an error event with Collector as its source.

Figure 26. An error event with the Collector as its source shown in the Event 
Viewer.

Figure 25. 
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3 Double-click on the event.

The Event Properties window appears. The text in the Description text field shows 
that the Collector service is unable to connect to the database. 

4 Open C:\Program Files\Ascom\Unite Log Collector\
Ascom.Analyser.Collector.exe.config for editing in a text editor or XML editor.

5 Correct the Connection String parameter

6 Set the Debug parameter to "True" to turn on extensive event logging (set this 
parameter to "False" and restart the service when finished with the 
troubleshooting).

7 Save the file and exit the editor.

8 In the Start menu, select Control Panel>Administrative Tools>Services

9 In the Services window, right-click Ascom Unite Log Collector.

10 Choose Start.

Figure 27 on page 41 shows how a correctly configured Collector service should 
look in Services.

11 When 

Figure 26. 
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Figure 27. A correctly configured Collector service as shown in the Services window.

Figure 28 on page 41 shows the events generated by the Unite Log Collector in the 
Event Viewer. Several events are generated because the Unite Log Collector is 
running in debug mode. 

Figure 28. The Event Viewer showing the events generated by the Unite Log 
Collector in debug mode.

8.2.2 The Unite Log Collector Stops Collecting Log Files

If the Unite Log Collector stops collecting log files, no new events show up when 
analysing log files in the Unite Log Analyser and the log files are not deleted from the ftp 
server.

1 In the Start menu, select Control Panel>Administrative Tools>Services

2 In the Services window, check that the SQL Server is started.

If it is stopped, right click on the service and select "Start".

3 In the Services window, check that the Ascom Unite Log Collector is started.

If it is stopped, do the following:

4 Open C:\Program Files\Ascom\Unite Log Collector\
Ascom.Analyser.Collector.exe.config for editing in a text editor or XML editor.

5 Set the Debug parameter to "True" to turn on extensive event logging (set this 
parameter to "False" and restart the service when finished with the 
troubleshooting).

Figure 27. 

Figure 28. 
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6 Save the file and exit the editor.

7 In the Start menu, select Control Panel>Administrative Tools>Services

8 In the Services window, right-click Ascom Unite Log Collector and select "Start".

1 In the Start menu, select Control Panel>Administrative Tools>Event Viewer.

2 In the Event Viewer window, click Application.

3 Look for any error events with Collector as its source.

4 Double-click on the events.The Event Properties window appears. Copy the text in 
the Description text field for each of the error events and paste the descriptions into 
a text file. These descriptions will be needed by Ascom technical support to track 
down the problem.

5 Contact Ascom technical support.

8.3 Troubleshoot the Unite Log Analyser

9 Related Documents

System Planning Unite TD 92258GB

Installation and Operation Manual, ESS TD 92253GB
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